【もっと快適に】WordPressで必ずインストールするべきプラグイン

シェアする

  • このエントリーをはてなブックマークに追加

【もっと快適に】Wordpressで必ずインストールするべきプラグイン

こんにちは。

ブリュの公式ブログ.netにお越しいただきまして、ありがとうございます。

このサイトは、IT関係について説明しています。

今回は、WordPressでサイトを運営するときに便利なプラグインについて紹介します。

ここで紹介するものはほぼ必須と考えていいでしょう。

なお、セキュリティに関する必須プラグインは、別の記事でまとめました。

この記事では、WordPressでのサイト運営が快適になるプラグインを紹介します。

スポンサーリンク

サイトマップを自動作成:Google XML Sitemaps

WordPress定番のプラグインといえば、Google XML Sitemapsです。

記事の新規投稿や更新を行うと、自動でXML形式のサイトマップを作成してくれます。

もちろん、当サイトでも利用しています。

バージョン3までは、sitemap.xmlに記事一覧を記載していました。

しかし、バージョン4になってから、サイトマップインデックス形式となり、sitemap.xmlの内部にツリー構造になった月別のsitemapを作成するようになりました。

この仕様変更より、一時は動作が不安定になるので、Google XML Sitemapsを3.4.6にダウングレードすることで利用している方もいましたが、現在では順調に動いています。

GoogleやBingへのPing送信機能もあるため、Googleサーチコンソールでわざわざ操作をしなくても、記事更新を伝えられるのが便利ですね!

※Ping送信とは、新着記事のリストを持っているPingサーバーに、記事の更新を伝える行為をいいます。

なお、Google XML sitemapsを利用する場合には初期設定で必要な項目があります。

これに関しては、個別の記事で説明していくことにしましょう。

Google XML Sitemapsのインストールと初期設定

大きな画像を圧縮・軽量化:Imsanity

Imsanityは、大きな画像を圧縮できるプラグインです。

画像を多用するサイトの場合、サーバー負荷軽減や、表示速度の高速化などの恩恵を受けることができます。

当サイトでは、画像の横幅を1024pxに指定し、画質は90%で設定しています。

90%の画質劣化は、人間の目にはわからないレベルでありながら、元画像に対して大幅にファイルの圧縮を行える値なのでおすすめです。

スポンサーリンク

ビジュアルエディタが使いやすくなる:TinyMCE Advanced

TinyMCE Advancedは、ビジュアルエデイタを使いやすくするプラグインです。

個のプラグインを有効にすると、文字サイズの指定をptからpxに変更できたり、メニューバーから文字色の変更ができたり、表を書くことができたりと、快適なWordPress運営を行うにあたって必須のものです。

こちらも紹介します。詳細設定が必要なので、個別の記事で紹介するとしましょう。

ここまでが必須であるWordPressのプラグインです。

次に、いざというときに役立つ、文字列の一括変換プラグインである「Search Regex」について紹介します。

文字列の一括変換:Search Regex

このSearch Regexプラグインが役立つのは、WordPressをSSL化したいときです。

初めからWordPressをSSL化して運営している場合には問題ないですが、初めはHTTPで運営しており、途中でSSLを導入してHTTPS化した場合、サイト内のすべての内部リンクをhttp://~から、https://~に変更する必要があります。

その時に、もれなく変換してくれるのが、このSearch Regex プラグインです。

また、機会は少ないでしょうが、SSL化以外にも、サイト名の変更時に、サイト内のすべてのサイト名を新しいサイト名に変更することもできますね。

インストールしておくと何かと便利なプラグインが、このSearch Regexプラグインです。

使い方は、個別記事で説明するとしましょう。

利用する際は必ずデータベースのバックアップを取ってください。

非常に便利なプラグインである反面、失敗すると大変なことになります。

まとめ

WordPressを始めるにあたり、必須であるプラグインについてまとめました。

これ以外にも便利なプラグインはありますが、最低限といえばこれぐらいでしょう。

他にもセキュリティ系のプラグインなどもあり、WordPressに多いブルートフォースアタックを防ぐプラグインもあります。

こうしたプラグインについても、かならずインストールしておいてください。

以上、WordPressでサイトを運営する際の参考になれば幸いです。

ご不明な点は、 お問い合わせからお願いします。

記事内容と関係性に関わらず、純粋にわからないこと情報提供各種コメントなど、お気軽にどうぞ!

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする